Simple Video Editing Using iMovie

Introduction: This tutorial will walk you through the capture, edit and export of a simple movie using the iMovie software available on all Apple Macintoshes.  iMovie lacks a lot of features available in other video editing packages such as Premier and Final Cut Pro and is only available on the Mac, but it has two very large advantages

1. It’s extremely simple to use

2. It’s free

The version of iMovie shown in the examples here is the OSX 3.0 version:  OS9 is restricted to the older iMovie2 which lacks some features.

We’re going to make a video for prospective students showing why Randolph College is the place for them!

Terminology and Technical Notes:  Video editing has a large number of terms you may not have heard before.  Most you won’t need to know to make nice videos, but a few are helpful to know.  (See the glossary for more terms) 

The first thing is the difference between analog and digital video.  The former is what we deal with when we use most TVs, VCRs and the like- the video is stored as a waveform.  In order to get the computer to understand analog video, we must convert it to digital format.  We can do this using the Dazzle analog<->digital bridge available in the Media Center.  If you want to know how to use this, talk to Eric.

The other way to handle this is simply to start with digital video.  Many high-end camcorders record in digital formats already: we have a Mini-DV camcorder available in the AV department.  We’ll be capturing video from this using a Firewire cable for the tutorial. 

One concern when working with video: digital video files are huge.  3 minutes of uncompressed video will fill a CD-ROM- they use about 200 MB/min.  In general, when editing video you want to have 3x of the size of the video available on your hard drive so that the editing program doesn’t run out of scratch space.  The machines in the Media Center have about 10GB free on their hard drives: that means we probably don’t want to edit anything longer than 3GB = 3000MB/200 MB/min = 15 minutes.  If you want to be the next Spike Lee consider buying a very large HD.

Cinematography is a non-trivial art: learning how to best use a video camera is beyond the scope of this tutorial.  One hint, however: when recording, press play, then wait five seconds before doing anything you care about.  Camera video heads take a second or two to spin up and nothing will be recorded until they do.

iMovie Layout:  To begin, start iMovie by double-clicking the icon.  When iMovie finishes the intro animation, select “New Project”.  iMovie will now appear with a blank project.
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There are 3 main areas in the program

1. The Monitor shows the video.  The controls at the bottom of the window act like a VCR: you can play, pause, fast forward, etc.  These controls will also control a Firewire equipped video camera when capturing video.

2. The Clip Bin stores pictures and video snippets.  The tabs on the bottom let you access editing features such as transitions and titling.  Note that under the Clip Bin there is a little “Free Disk Space” gauge.

3. The Timeline shows how the video clips will be assembled, as well as transitions, extra audio information and the like.
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Capture:  To edit a video, we need to have some digital video to edit!  Eric has made a short tape with about 2 minutes of video snips of Randolph College on it using the GL-1 camcorder. 
Connect the GL-1 to the computer using a Firewire cable.  Turn on the camcorder to VCR mode.  If iMovie doesn’t automatically switch to “Digital Video Capture” mode, move the small selector under the Monitor to the left. You should see a blue screen with the message “Camera Connected”. iMovie can now control the camera using the buttons under the monitor.  Click the Play button to see the start of the video.  Click it again to stop, then press the Rewind button to reset the tape.
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In DV capture mode, a small “Import” button appears above the controls.  To capture all the video, click Play then click Import. (Note: the reverse order will not work.) Both buttons should turn blue and the video will begin to play.

As the video plays, the clips will appear in the Clip Bin.  Each time the camcorder was stopped during taping will create a new clip, so by the end of the import you should have 7 clips.  (Note: the tape has been reused: stop the tape when you see Kathleen speaking.)
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Each clip in the clip bin has a number on top, such as 26:03.  This is the duration of the clip: 26 seconds +3 frames.  NTSC video is 29.97 frames/second, so the last number will run between 0 and 29.  Thus, this clip is just over 26 seconds long.

To view a clip once you have captured it, move the capture slider back to the right and then click on the clip in the Clip Bin.  You can now play the clip. 

Keeping an eye on disk space: Off to the lower right of the widow is a small thermometer gauge that measures the amount of disk space remaining, along with a trash icon that shows how much space the trash is taking.  Don’t let the thermometer drop [image: image6.jpg]


below 1GB: it’s better to keep it well above that level. (Remember, 1GB is only 5 minutes of video.) Empty the trash frequently.

Importing from sources that are not digital cameras: iMovie understands only digital video input. If you want to capture from a source such as an analog VHS tape, you need to convert it to digital first.  You need a specialized piece of hardware for this, either a video card with external video capture or (more easily with a Mac) an external analog<->digital bridge.  We have several on campus (Formac Studios): contact Eric or DD for details on using one.

Choosing the Clips:  Not all of these clips are useful.  The one where I get lost in the library (Clip 2) is probably not one you want to show, nor is the one showing Kathleen speaking.  Simply drag the clip(s) to the trashcan icon under the clip bin to dispose of them.
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Worse, some of the clips have bits in them you don’t want.  Clip 1 has a section where the student scratches herself, and then some with Maria badly backlit.  iMovie allows us to crop these bits out.  Select Clip 1 and look at it in the viewer.  Note that you now have a blue bar under the Monitor with a little triangle above it and a timecode next to it: this is the Scrub Bar and Playhead, which allow you to move back and forth in the clip quickly.  
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We’d like to only keep the bit where the student is speaking at the end.  Move the playhead to the 14:14 point in the video.  If you can’t hit it exactly, you can move frame by frame using the arrow keys on the keyboard.  This is where we’d like to start the video, so we’re going to crop out what we don’t want.

Click and drag in the hash-marked area directly below the scrub bar.  When you do this, you’ll see two half triangles appear and the part of the scrub bar between them will turn yellow.  Anything yellow is the selected area.  Since we want to select everything after the 14:14 point, drag the right half-triangle all the way to the right.

Now go to the Edit menu and select “Crop”.  Only the part that we wanted is now left- the rest has been thrown away.

What would you do if you wanted several different parts of the same clip?   Simply place the playhead at the point you’d like to break the clip apart and select Edit->Split Video Clip at Playhead.  You’ll now have two clips that you can use independently.

Assembling the Video:  We have all the video clips we want, but they aren’t in a very good order.  I think we’d like to start with the outdoor shots (3+7), followed by the class (1), the food (6), parking (5) and finally the equipment (4).

Assembling the clips in order is simple.  Look just above the timeline on the left and you [image: image9.png]


will see two buttons: the left puts the timeline into “Clip mode”, the right switches to track view.  Click the left button then simply drag the clips from the Clip Bin into the Timeline in the order that you want.  Each time you do so the clip disappears from the Clip Bin.[image: image2.png]Ciip 07 Ciip 01 Ciip 06 Clip 04




Don’t like the order?  Just drag them around.  I think I’d actually rather have the slide rule after the class- grab it and drag it after the clip of the class.

Want to get rid of a clip?  Just return it to the Clip Bin.

Advanced Timeline: In Clip View, the timeline just shows the order of the clips.  This is very handy for dealing with a rough cut, but you’ll often want to know more about how long each clip will take, what other sounds are layered with the video, etc.  Click the clock icon button on the upper left of the timeline to see the timeline view. iMovie video is made up of 3 tracks, 1 video and 2 sound tracks.  (There are actually 3 audio tracks: the video track also includes an audio track) The top track shows a small version of the video clips: the length of the clip shows the duration of the clip.  The bottom 2 tracks are for audio- you can play multiple audio tracks at once, so you can have voiceover and a music track playing at the same time.
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You can zoom in or out on the timeline with the slider on the left.  The center slider will speed up or slow down a track, which can give you some interesting effects.  (For those who saw The Show video, the “Trading Spaces” spoof was done by speeding up a clip.)
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Titling:  Every good movie has a title with credits: how else would people know who did the work?  iMovie has a built-in titler.

Click the “Titles” button under the clip bin to get the titling window.  The bottom two boxes control what text you’d like.  Enter “Wonderful Randolph College” into the top one and “By (your name)” into the bottom.  

Right above the text boxes you can choose the font and size of the text- pick any one you want, but be aware that small text and fancy fonts show up very poorly on TV screens and small computer videos.

Just above that you can choose the color of the text and if you want it on a black screen.  If you don’t choose “Over Black”, the title will appear over some of the video.  This can appear cluttered, so check Over Black for now.

Finally, the center window lets you choose how the text will appear.  There are tons of options: choose one you’d like.  Clicking the “Preview” button at the top of the window lets you see what it looks like.
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Once you’ve decided on a format for the title, we want to add it to the start of the movie.  Grab the type of title you’ve chosen and drag it to the Timeline in front of the first clip.  You’ll see a new clip appear with a small red bar under it.  The red bar means that the clip is rendering: the computer is adding it to the movie.  When the red bar is gone the title is ready.

Adding Transitions:  Click Play now to watch your movie.  Everything should play in [image: image12.png]Preview
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order now, with a nice title.  However, the transitions between the clips are a bit jarring: professional videos rarely use hard cut after cut.  We’d like to add a transition to soften the move between clips.
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Click the “Transitions” button under the Clip Bin and the Transitions window appears.  iMovie has a small set of built in transitions.  For now, select “Cross Dissolve”, which fades the old clip out and fades the new one in.  Drag the transition from the list in between clip 3 and clip 7, the two outdoor clips and you’ll see the transition icon appear.  Once again, you get a red bar as the movie renders.  Wait until the red bar goes away and watch the movie again.  Much nicer, no?

You can adjust the settings for a transition using the various sliders and controls that appear with the transition.  For a cross-dissolve, the only control is the length of time the dissolve will take: you can vary this from 10 frames (~1/3 of a second) to 4 seconds.  If a clip isn’t long enough to fit a transition, iMovie will tell you.

Adding Visual Effects: Want to put in some special effects?  iMovie offers a variety of tricks to make your movies look funky.  Click the “Effects” tab under the Clip Bin and a series of possible effects will appear.  Some of these are useful, some just fun.  Select the clip you want to apply the effect to, select the effect and then click the “Apply” button.  A small red line will appear along the top of the clip while iMovie renders the changes.  Be aware that many of these effects are tremendously CPU intensive: you can do other things to the movie while rendering, but it make take hours or days to apply a complex effect to a good chunk of film. The “useful” ones are

· Adjust Colors: let’s you change the Hue. Saturation and Brightness of an image

· Brightness&Contrast: Exactly what it says

· Sharpen: Similar to the Unsharp Mask in Photoshop, it will accent edges in the picture and help make an out-of-focus picture less blurry.

Adding Pictures: You can import pictures into iMovie and have them appear anyplace within your film.  Go to File->Import and find a JPEG photo.  iMovie will import it into the Clip Bin and give it a default duration of 3 frames.  This is a bit short: there are two easy ways to increase the length

· Select the photo in the Clip Bin and go to Edit->Create Still Frame. This will create a clip of 5 seconds duration.  You can do this multiple times if you want.

· Click the small timeline button just above the timeline on the left to show the tracks of the movie.  Use the clip speed slider to make the clip go more slowly.
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Disabling the “Ken Burns” effect. Apple, in a triumph of glitz over common sense, has fallen in love with the “Ken Burns” effect, so named for the director of documentary films about topics like the Civil War.  This effect pans and zooms across still photos: place a still photo in the timeline to see what it looks like.  Note you didn’t have to turn it on: Apple has decided that this is the default for all photos.

While occasionally appropriate, it’s overused and often unwanted.  To control the effect, click on the still clip in the timeline and then click the “Photo” button under the Clip Bin.  

You can control the speed and the amount of zoom with the controls shown: to turn the effect off entirely, select the “Start” button and set the Zoom to 1.00, then click the “Finish” button and set the Zoom to 1.00 as well.

Audio in iMovie: As mentioned above, iMovie lets a movie have up to 3 independent audio tracks, one attached to a video clip and the others in separate audio tracks.  All 3 will blend together when you listen to the final product.

On the far right of the timeline are checkboxes attached to each track: if the box is checked, you will hear the audio from that track, otherwise the track is silenced.

You can adjust the volume of any clip by selecting the clip and then adjusting the volume slider on the bottom of the timeline.
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Adding Sound Effects: Every great movie has a sound track and sound effects.  iMovie lets you add narration, music and sound effects to your movie.  Click the “Audio” button under the Clip Bin to see the possibilities.

The top 3rd of the window gives some built-in sound effects.  Click on one of them to hear the clip.  To spice up the intro, lets add the “Indoor Laugh” effect to the title of the video.

[image: image16.png]N 97MB | 20.38CBfree = |




Click the Clock button on the left of the Timeline to see the video and audio tracks. Drag the “Indoor Laugh” effect out of the bin into the 2nd audio track under the title.  A purple bar between two triangles appears: this indicates the length of the effect. You can move the effect around by click+drag, or change the duration by click+drag on the triangles at the end of the clip.  Watch the movie now and you’ll hear the sounds.

You can have multiple effects in the same track. Drag another effect onto track 2 at the same time as the first and listen again- you’ll hear both.

The laughter is a bit overbearing: why not tone it down by about 50%?  The clip outside of Leggett is a bit louder than the rest of the audio tracks, so click on the video clip and reduce the volume there as well.  

Listen to the movie again and you’ll note a flaw: you need to reduce the volume on the transition between the shot of the front of campus and the Leggett one as well.  Click on the transition icon in the timeline and reduce the volume for the transition.

If you want, you can also add a voiceover or CD music.  For voiceover, simply click the red button next to the “Microphone” label and speak into the microphone.  Click it again when done.  The voiceover track appears in the timeline where the playhead is; you can move it if needed.

Adding Music: Insert a CD and start iTunes from the Dock.  Click on the CD icon on the left, then drag the track that you want to the Library icon on the left.  ITunes will convert the track to an MP3 file suitable for import.

Go back to iMovie and select “iTunes Library” from the pulldown menu at the top of the audio window.  You’ll see a list of the available music: simply drag a tune into an audio track.

Advanced Audio: Extracting:  If you watch many interviews, you’ll note that they usually use two cameras, one on each person.  Frequently, they will focus the camera on the interviewee while the interviewer is asking the question so you can see their facial expression.  You can do this will iMovie as well.

Each video track contains an audio track attached to it.  You can remove this audio track by selecting a clip and selecting Advanced->Extract Audio. The audio will appear on the first audio track in the timeline and the original video clip will be silenced.  You can then move the audio track under another video clip.  

Advanced Audio: Keyframed audio:  One of the best new features of iMovie 3 is much more subtle control over the volume of the video.  Select a clip and then make sure the “Edit Volume” button on the bottom of the timeline is checked.  
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You will see a purple line across the clip: this is the volume of the clip at any given point.  Click and drag on this line and you will set a new volume keyframe.  You can set as many keyframes as you would like, so the volume of a given clip can vary wildly while it’s playing.  This can be very useful if your source tape has widely varying input levels: the author of this document did a huge amount of this (using a more sophisticated editor than iMovie, however) to produce The Show video, trying to amplify the quiet performers and mute the cheering crowd.

Export: Let’s output this to a computer video so that we can put it on the Randolph College web page for prospective students.  

Once we’re finished with the movie, select File->Export.  The Export window appears.  iMovie can export back to the camera, to a computer-viewable QuickTime movie, or to iDVD, an Apple program that can create DVD disks that will play in a consumer DVD player.  The first option isn’t all that useful: very few people have Mini-DV VCRs, so few people will be able to watch the tape.  The latter is useful if you have a DVD-R drive, but for now we’ll just export in a format for the web.

Select QuickTime from the Export: pull down menu.  You’re given a Format: pull down menu that allows you to choose a several options for the movie.  Remember that digital video files are huge: most of these options are designed to make the movie much smaller in size so that downloading it doesn’t take months.  In the process they also make the movie lower in quality: they do things like reduce the size of the frames (From DVs 720x480 pixel window to 240x180, for example.) reduce the number of frames per second (from DVs 29.97 to 12), and reduce the sound from stereo to mono.

In addition they compress the data using software that does tricks like analyzing the movie to look for similar/non-moving areas and simply repeat them from previous frames.  All of these will make the movie much less crisp and clear: if you want maximum impact keep the movie at full DV level, but be aware that it will take minutes to download on Randolph College’s internal network and days over a modem.

Since we want prospective students to watch the movie from home, let’s choose the Web option.  This will be a decent size when finished.  Simply select the Web option, click Export then give it a name.  The process will take several minutes: compressing video is one of the most computationally hard tasks a PC will ever do.  Once done, you have a QuickTime movie anyone can view.

My copy of the small movie weighs in at 2.5MB- yours will probably be a bit different due to different choices you made.  To give an idea of the difference between the Web Movie setting and full DV, the same movie was 194.3MB uncompressed: roughly 77 times larger.

Expert Export: If you want more control over the whole process, you can choose “Expert Settings” from the Export pull-down menu.  Click “Export” and you will get a standard save dialog, but you will also have an “Options” button on the lower right.  Click “Options” and you will get a menu where you can set the exact audio and video settings you want.

For example, say that you have a movie with high detail but one that’s very static: very little moves in the frame.  In that case, you probably want to have a large window size, high quality compression but to save space you could have fewer frames/second.  [image: image18.png]


Click the “Settings” button under Video and you can set the compression quality and frames/second, the Size button lets you set the size of the movie.

You can save some additional space by lowering audio quality as well (or perhaps that’s most important) CD-quality sound is 44.1 KHz sample rate, 16-bit size and 2 channel, uncompressed.  Lowering any of these settings will worsen the audio but save space. 

Exporting to videotape: Videotape is analog, so just as we needed a bridge to get analog video into iMovie, we need a bridge to translate the digital video out to a VCR.  The Formac Studio bridges we have on campus work both ways.  If you need an analog videotape made of your movie, contact Media Services at x4133 to have it converted.

Glossary:

· Analog video: Video stored as a waveform.  Many camcorders, VCRs and TV signals are analog.

· AVI: A video format used on Windows computers.  Replaced by WMV.

· Capture: The process of taking video from a source onto a computer.

· Codec: Compressor/Decompressor.  A piece of software that converts video from compressed to uncompressed format and back.  There are numerous codecs: Apple uses Sorenson and Cinepak frequently.

· Digital video: Video stored as a series of 0’s and 1’s.  Video needs to be in digital format to be edited on a computer.  High-end camcorders and mini-dish satellite TV (Such as Dish Network) use digital video.

· Export: The process of taking computer video to another source.

· Firewire: Also known as iLink or IEEE 1394.  A fast interface used to connect devices such as video cameras to computers.

· Frame: A single picture: a video is made up of a number of frames shown sequentially.

· MPEG: A set of digital video compression standards.  Most computer video players understand MPEG formats.

· NTSC: The format used for analog video in North America.  720x480 pixels, interlaced, 29.97 frames/sec.  (Often referred to as “Never The Same Color”)  Other countries use PAL or SECAM instead.

· Pixel: Picture element.  A single dot in a still or video image.  

· QuickTime: Apple’s video format.  Actually much more than a simple format, but can be treated as one.

· WMV: The current native video format in Windows.  Supercedes AVI.

